Prés requis

Pour que Plasmide fonctionne correctement, vous devez verifier les points suivants:

PHP

- Votre serveur web doit disposer de PHP version 5.2 minimum.

- La bibliotheque GD ou ImageMagic doit etre activée pour PHP.

Nginx

Plasmide est prévu pour fonctionner sur Nginx (serveur web). Vous devez avoir acces a sa configuration et la modifier comme tel :

location / {
    try_files $uri /router.php$is_args$args;
        
}

# pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000

location ~ \.php$ {
    fastcgi_pass unix:/var/run/php5-fpm.sock;
    fastcgi_index index.php;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;

    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    # NOTE: You should have "cgi.fix_pathinfo = 0;" in php.ini

}


location ~ ^/router\.php(/|$) {
	fastcgi_pass unix:/var/run/php5-fpm.sock;

	fastcgi_split_path_info ^(.+\.php)(/.*)$;
	include fastcgi_params;
	fastcgi_param SCRIPT_FILENAME $realpath_root$fastcgi_script_name;
	fastcgi_param DOCUMENT_ROOT $realpath_root;
	
	internal;
}   

Note : Plasmide fonction egalement avec php 7 en remplacant la ligne

fastcgi_pass unix:/var/run/php5-fpm.sock;

Par :

fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;

Si ces points sont vérifiés, vous pouvez passer à la section Installation.